Sysadminsblog.com Anything for sysadmins!

7Dec/123

PST Capture errors

I’m currently in the process of configuring PST Capture in order to migrate all the user’s PST files to the recently configured cloud based Online Archive. As this wasn’t working properly, I contacted Microsoft and opened a support ticket. I’m getting the error “Import error: Error opening mailbox <mail address>” when I try to import the PST file into my Online Archive. During the troubleshooting of this error I came across a nice list of requirements for the PST Capture tool to function properly. This might help you to configure everything correctly.

  1. Please make sure that you have the 64 Bit version of Outlook installed and that it is installed on the machine on which PST Capture Tool is running.
  2. Please check if the user has the Mailbox Import Export permissions. If it does not have them, then please assign them using the following command:
    </em>New-ManagementRoleAssignment -Role "Mailbox Import Export" -User "PSTImportUser"
  3. Please check that the Microsoft Exchange PST Capture Tool’s Service Account has an Exchange 2010 Mailbox.
  4. Please check that the PST Capture Tool’s Service Account is a member of Local Administrators Group.
  5. Please make sure that the PST Capture Tool’s Service Account is a member of Organization Management and also the Public Folder Management.
  6. Check that the Service Account is mailbox-enabled and has an Outlook profile configured for it.
  7. Please make sure that the correct Service Account is chosen for the PST Capture Tool. To do this, please go to Properties of ‘Microsoft Exchange PST Capture Service’ > Log on tab  and check the Service Account.

 

Please comment below if you have questions about the PST Capture tool, or the above settings.

Be Sociable, Share!

Posted by Mischa Oudhof

Comments (3) Trackbacks (2)
  1. Thank you very much for sharing. This helped us fix this problem in our PoC environment.

  2. Did you try it with Online archive? As I can make it to upload pst to the online archive but the local one it can

    • Yup, I tried both, but only local worked. It doesn’t seem to work when you only use Online Archive without Office 365 mailbox attached. I opened a ticket with Microsoft, and even they couldn’t figure it out.


Leave a comment