Sysadminsblog.com Anything for sysadmins!

31May/100

Problems uninstalling Exchange 2010

I recently had to uninstall an Exchange 2010 server and take it out of a DAG setup. This didn’t go as flawless one might expect. During the installation of Update Rollup 3 for Exchange 2010 the installation process crashed. This caused all kinds of problems, but the most obvious one was that the Outlook Web App was returning 404 errors.

In all my hurry to solve the problem I didn’t make any screenshots. The CAS, and MBX roles were uninstalled successfully, but the HUB Transport role was returning the error:

The following error was generated when “$error.Clear(); uninstall-MsiPackage -PackagePath ($RoleInstallPath + “Mailbox\MSFTE.MSI”) -LogFile ($RoleSetupLoggingPath + “\InstallSearch.msilog”)” was run: “Couldn’t open package ‘C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\MSFTE.MSI’. Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel. Error code is 1638.”.

Couldn’t open package ‘C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\MSFTE.MSI’. Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel. Error code is 1638.

After a bit of searching I found this article which indicated that I should reinstall Update Rollup 3 and then it should all work again. I reinstalled Update Rollup 3 twice after which I was able to uninstall the HUB Transport role and completing the uninstall of Exchange 2010.

Be Sociable, Share!

Posted by Mischa Oudhof

Comments (0) Trackbacks (0)
  1. Copy :\Setup\ServerRoles\Mailbox\MSFTE.MSI to C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\


Cancel reply

No trackbacks yet.