Sysadminsblog.com Anything for sysadmins!

24Mar/113

Event 1004, 1001, 1015 – Microsoft.ResourceManagement.Service.exe

While setting up the User Profile Synchronization services on SharePoint 2010 I had a couple of warnings and errors that I had to address. This one seemed worth mentioning.

Detection of product '{90140000-104C-0000-1000-0000000FF1CE}', feature 'PeopleILM', component '{1C12B6E6-898C-4D58-9774-AAAFBDFE273C}' failed.  The resource 'C:\Program Files\Microsoft Office Servers\14.0\Service\Microsoft.ResourceManagement.Service.exe' does not exist.

Followed by event 1001:

Detection of product '{90140000-104C-0000-1000-0000000FF1CE}', feature 'PeopleILM' failed during request for component '{9AE4D8E0-D3F6-47A8-8FAE-38496FE32FF5}'

And event 1015:

Failed to connect to server. Error: 0x80070005

These were repeated for another component GUID.

The reason is that the WMI calls are made under the credentials of Network Service account and that this account doesn’t have permissions on the folder indicated in the event.

After I gave the Network Service account read and execute permissions on the folder the events didn’t reappear.

Update:

After a couple of hours I noticed new events in the event viewer related to the previously mentioned.

Event 1004:

Detection of product '{90140000-104C-0000-1000-0000000FF1CE}', feature 'PeopleILM', component '{CF90B971-D78A-4794-8F90-EB5FB5028DDA}' failed.  The resource 'C:\Program Files\Microsoft Office Servers\14.0\SQL\DatabaseSettings.sql' does not exist.

Event 1001:

Detection of product '{90140000-104C-0000-1000-0000000FF1CE}', feature 'PeopleILM' failed during request for component '{9AE4D8E0-D3F6-47A8-8FAE-38496FE32FF5}'

Be Sociable, Share!

Posted by Mischa Oudhof

Comments (3) Trackbacks (0)
  1. Just add read&excecute permissions to the network servide on the 14.0 folder

  2. Really a lsefiaver…..I spent a couple of Hours Trying to Understand what was happening with my Dev box without any Luck…Great Post….

  3. Thanks for this useful article,
    The problem is there is no %programfiles%\Microsoft Office Servers\14.0 folder on our SP2010 server

    Could you please advise?
    Regards,


Leave a comment

No trackbacks yet.